Unable to restore Infinera DNA database

The other day, restoring Infinera DNA database, the process just died. No errors, no indication as to what the problem might be. The following output in restore log was the only thing to go by:

2021-03-15 16:06:17,146 Created VIEW OTM_SLOT_UTILIZATION_DETAILS
2021-03-15 16:06:17,324 Created TRIGGER NBM_LMBWTHRESHOLD_UPD_TRG
Dropping CNM triggers...
2021-03-15 16:06:17,977 Successfully dropped trigger CNM_ALERT_TRG
2021-03-15 16:06:18,152 Successfully dropped trigger CNM_ASSOCIATION_TRG
2021-03-15 16:06:18,327 Successfully dropped trigger CNM_EVENT_TRG
2021-03-15 16:06:18,502 Successfully dropped trigger CNM_FIBERLINK_TRG
2021-03-15 16:06:18,677 Successfully dropped trigger CNM_ME_TRG
2021-03-15 16:06:18,852 Successfully dropped trigger CNM_OTSPTP_TRG
2021-03-15 16:06:19,027 Successfully dropped trigger CNM_SNCLOCAL_TRG
2021-03-15 16:06:19,203 Successfully dropped trigger CNM_SUBSNCLOCAL_TRG
2021-03-15 16:06:19,378 Successfully dropped trigger CNM_SYMBOL_TRG
2021-03-15 16:06:19,553 Successfully dropped trigger CNM_TRIBPTP_TRG
2021-03-15 16:06:19,901 Successfully dropped trigger CNM_XCON_TRG
2021-03-15 16:06:19,901 Dropped CNM triggers...
Dropping XCONCLR trigger...
2021-03-15 16:06:20,075 Successfully dropped trigger HTBL_XCONCLR_AI_TRG
2021-03-15 16:06:22,161 Please wait while DNA server creates the table partitions.


Please wait ! Restoration is in Progress..................... |

Check the latency between the backend server and the database server. This happened when latecy was around 160ms.

Prior Cold start completed successfully so, that comfirmed there was no problem with database server itself or the connection between the database server and the backend server.